Spa footwell light not functioning.

  1. have a 2012 Sundance Capri who’s footwell light gave out. replaced the light and still does not work. What could be the problem?

Replies

  1. Nigel

    Reply

    Paulene check all your connections first. If all your connections are good you could have a bad control panel, DCU or transformer. First try a spare control panel. If you have lights after that replace the panel. If you still have no lights after trying a spare panel verify you have 12-14 VAC present at your transformer yellow power wires. If you have no voltage you could have a bad transformer. If you have voltage you could have a bad DCU.

  2. paulene michels

    Reply

    Update: I do have 13 VAC present at wires to the transformer even after replacing the DCU. Noticed that the original DCU had a burnt mark on the back of the unit, above where the the ribbon plugs into the yellow plug in. The new DCU also is hot to the touch after installing it, on the same area as the previous on.. Going to disconnect it until I hear back from you. What could be causing this? Still No lights. Should I try a new top side control panel? All the jet buttons work-hear a clicking sound, but not from the light buttons. Thank You!

    • Nigel

      Reply

      Paulene if all your wires are properly connected from the transformer to the DCU and you have 13VAC you should see a blue light illuminated on the DCU. If you see the Blue light you are getting some power to the DCU. Unplug all of your lights from the DCU and check each one indivdually to see if any lights in the spa work ie air control lights, waterfall lights. Sometimes individual zones can burn out on a DCU because of a faulty light. Usually the footwell light is the most reliable light compared to the waterfall and air control lights. Once you find a zone that works start plugging your lights one by one into that zone. Take notice each time you plug in the light for any flickering of the light or a light that does’nt show all the colors. A light that flickers or does’nt show all the colors could be a bad light that needs replacing. A bad light can burn out a port or a zone but usually will not take out the whole DCU. If you are left with less good ports or zones on your current DCU to supply all your lights a DCU expansion box is available.

  3. Ray

    Reply

    Hi there. Sorry to side track this thread. Can you tell me where you found your dcu? I have a Subdance altamar, have the same issue but there is no dcu near the sentry board. I know I have one because I have multiple lights and the Aquaterrace secondry comtrol panel. Lights just stopped working. Have power from transformer but cannot find DCU thanks

    • Nigel

      Reply

      Ray follow the ribbon cable from your footwell light to where it terminates. This should lead to the DCU. If you require a new DCU please let me know your serial number and date built of your Altamar and I can send you a link to our parts area with prices for that specific item.

      • Ray

        Reply

        Hi, Thanks I will do that. Any hints on which side of the spa I should open, to find this cable? I have a deck all around so i would like to save disassembling the wrong side of the deck 🙂 If I am looking at the spa from the side of the main board and the water fall away from me would it be easier to access the DCU / Footwell light ribbon from the left or right side?

        • Nigel

          Reply

          Ray it will make no difference either from the right front or left front panel to access the ribbon cable. To find out where the DCU is you will have to follow the ribbon cable to where it terminates. If you don’t see the DCU behind the right front or left front panels you will likely need to remove the left, right and or waterfall side panels to find the DCU.

  4. James

    Reply

    2014 Sundance Cameo – Top side LED lights will not shut off (waterfall and rings around the diverters) but when pressing the on/off button the foot well light responds accordingly. Power cycling the tub does not resolve the issue, top side lights are still on 24 hours per day.

    A few weeks ago, when we pressed the light mode button, all the tub lights would go out and you could not turn them back on without power cycling the tub. In addition, during this time, a portion of the foot well light would display a color different from the one selected. In other words, if green was selected the foot well light with display a few spots of red. I’ve disconnected the foot well light cable to see if I could power off the top side LEDs with no luck. Looking for any advise to further troubleshoot.

    • Nigel

      Reply

      James you may have one or more bad lights and or a bad DCU or topside control. First thing to do is to unplug all the ribbon cables at the Blue DCU box expcept your topside control. Locate the ribbon cable for you underwater light and plug this into a port on the DCU til you find a port that allows the underwater light to work. Once you have a good port unplug the underwater light, mark it and set it aside. Then start plugging in your other air control and waterfall lights one by one in the good port. Observe the lights to see if they work or don’t work or have limited color scheme. If any of the lights flicker unplug them immediately. A damaged light or lights can foul the whole lighting system and cause the symptoms you describe. If you would like a link to prices and availability of new lights and a DCU control please provide me with the serial number of your Sundance Cameo Spa.

  5. Lanny Kemble

    Reply

    I have a sundance marin 880 hot tub. the waterfall led lights are not working. I switched the lower light ribbon in the controller and confirmed it is a bad waterfall LED light. My question. How do you remove and replace the waterfall light bar?

    • Nigel

      Reply

      If the spa was built between 2007 and 2012 the light bar is glued to the acrylic with an epoxy Lanny. You need to cut the ribbon cable behind the skirt panel and then peel off the light bar with a scraper. The light bar likely won’t come off all in one piece so you’ll have to scrape away any leftover pieces and gently sand that area where the bar was so the new light bar can sit flush with the acrylic. You may need to drill out the hole where the ribbon cable was fed through as usually this hole is also filled with epoxy to keep water run-off from going through the hole: https://shop.aqua-tech.ca/products/sundance-spas-waterfall-light-pn-6560-177

  6. milo

    Reply

    Hope you can help – I have a similar,but different light situation. The well light to my 2007 Sundance Marin spa will not stop changing colors. Every few seconds it changes colors. Also of note there is a remote light control on the right side of the unit (next to filter) that also does not seem to work. Lastly, after opening the front left panel I noted that there is one cable that is not attached to what looks like a splitter (shown on all diagrams, but is not ever labeled). Any help or advice is appreciated.

    • Nigel

      Reply

      Milo, sounds like could be a bad remote panel or bad connection at that panel or a bad DCU. Try disconnecting the smaller remote panel and see if then the lights work from your larger main control panel.

Ask a Question or Comment